Project

General

Profile

Actions

Support #762

closed

Support #761: koha-illbackend-libris enhancements

Edit patron information before registration of arrival

Added by Lari Taskula over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
24.01.2022
Due date:
% Done:

100%

Estimated time:
Spent time:
Sponsored-by:
Koha Bugzilla Bug#:

Description

patron’s information No
before registration of
arrival of an inter
library loan without
the changes later
being written over
The changes should
be visible both in the
patron entry as well
as in the inter library
loan module.

This intends patron’s information for the
patron (and not the check-out library). It
should also be possible to edit patron-
information before registration of arrival.

Libris backend can currently be
configured so that data about libraries is
just retrieved once from Libris, and
afterwards is updated locally. See
«update_library_data» here:
https://github.com/Libriotech/koha-
illbackend-
libris/blob/master/docs/config.pod

What we figured is the problem is that
data from Libris that is imported into
Koha is overwritten by new data from
Libris. It should be possible to add a
field that says «Do not update» or
something similar, that is activated when
manual changes are made, that then
stops updates/overwriting.

Actions #1

Updated by Lari Taskula over 2 years ago

  • Status changed from In Progress to Feedback
  • Koha Bugzilla Bug# set to 22321
Actions #2

Updated by Lari Taskula over 2 years ago

  • % Done changed from 0 to 100
Actions #3

Updated by Lari Taskula over 2 years ago

  • Target version set to koha-illbackend-libris
Actions #4

Updated by Lari Taskula about 2 years ago

  • Status changed from Feedback to Resolved
Actions #5

Updated by Lari Taskula about 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF