Project

General

Profile

Actions

Bug #1104

closed

Bug 34639 - Item shown in transit on detail.pl even if marked as arrived or cancelled

Added by Lari Taskula 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
29.08.2023
Due date:
% Done:

100%

Estimated time:
Spent time:
Koha Bugzilla Bug#:

Description

To reproduce:

1. Add an item to library A
2. Go to Circulation -> Transfer
3. Transfer the item from library A to another library B
4. Set your currently logged in library to library B
5. Check-in the item
6. Observe message "Item received from A"
7. View the bibliographic record of the item (catalogue/detail.pl)
8. Observe item in "In transit from A to B since xx/xx/xxxx Available"

To test:
1. prove t/db_dependent/Koha/Item/Transfer.t

I do not yet understand why but something changed after prefetching current_branchtransfers. It returns a transfer even if it shouldn't when the transfer contains a datetime in datearrived or datecancelled.

Actions #1

Updated by Lari Taskula 10 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF